フロントエンドエンジニアもどきの備忘録

デザイナーやらコーダーを経てフロントエンドに落ち着きました。

PIXI.js

Pixi.jsでAndroid4.0系だけCROS時にSECURITY_ERR: DOM Exception 18 エラー

情報がなくて2日もはまってしまいました。。。 結論、Android4.0系の標準ブラウザでWebGLを使うとどうあがいてもこのエラーになる場合があります。なので、Canvasを使うようにしてあげるといいです。(4.1とかは大丈夫) PIXI.autoDetectRendererの第4引数…

PIXI.js用にスプライトのテクスチャをGulpで生成する

gulp.spritesmithとspritesmith-texturepackerを使います。 インストールは省略。 var gulp = require('gulp'); var spritesmith = require('gulp.spritesmith'); var spritesmith_texturepacker = require('spritesmith-texturepacker'); gulp.task('make_s…